Enable Crystal Reports 2011 Server AD Authentication

2012-04-24 / Random / No Comment

Solution:
Documentation is from SAP website that assisted me in enabling AD authentication

Crystal 2011 AD Authentication

Tags: , ,
Read More

EMC Engineering Mode

2012-02-16 / SAN / No Comment

In Navisphere CTRL-SHIFT-F12

password : messner

Tags: ,
Read More

Configure mediawiki for LDAP authentication with Microsoft active directory

2011-08-15 / Linux, Random, Server / 3 Comments

Problem:

Needed to enable  Microsoft Active Directory authentication to our internal mediawiki site.

Solution:

enable Ldapauthentication.php extension. modify localsettings.php file to include the following:

require_once( “$IP/extensions/LdapAuthentication/LdapAuthentication.php” );
$wgAuth = new LdapAuthenticationPlugin();
$wgLDAPDomainNames = array( “ADSITE” );
$wgLDAPServerNames = array( “ADSITE”=>”wcp01xdc.ADSITE.local”  );
$wgLDAPBaseDNs = array( “ADSITE”=>”dc=ADSITE,dc=local” );
$wgLDAPSearchStrings = array(“ADSITE” => “ADSITE\\USER-NAME”);
$wgLDAPSearchAttributes = array( “ADSITE”=>”sAMAccountName” );
$wgLDAPLowerCaseUsername = array( “ADSITE”=>true );
$wgLDAPRequiredGroups = array( “ADSITE”=>array(“cn=information technology,ou=users,ou=information technology,ou=ADSITE,dc=ADSITE,dc=local”) );
$wgLDAPGroupUseFullDN = array( “ADSITE”=>true );
$wgLDAPGroupsUseMemberOf = array( “ADSITE”=>true );
$wgLDAPGroupObjectclass = array( “ADSITE”=>”group” );
$wgLDAPGroupAttribute = array( “ADSITE”=>”member” );
$wgLDAPGroupSearchNestedGroups = array( “ADSITE”=>true );
$wgLDAPGroupNameAttribute = array( “ADSITE”=>”cn” );
$wgLDAPPreferences = array( “ADSITE”=>true );
$wgLDAPDisableAutoCreate = array( “ADSITE”=>false );
$wgMinimalPasswordLength = 1;
$wgLDAPUseSSL = false;
$wgLDAPEncryptionType = array( “ADSITE”=>”clear” );
$wgUseLocal = false;
#$wgLDAPDebug = 99;
#$wgDebugLogGroups[“ldap”] = “/tmp/wikildapdebug.log” ;

Replace “ADSITE” with the name of your domain. It is currently setup for clear text authentication. After you get clear text authentication working you should enable tsl or ssl authentication if need be.

the setting $wgLDAPRequiredGroups is optional and is used to allow only certain groups to login the wiki. in this case “Information Technology”

Tags: ,
Read More

PeopleSoft xmllink 302 : Site moved temporarily

2011-08-02 / PeopleSoft / 1 Comment

Problem:

After refreshing one of our environments the xmlink http://server/xmllink/fmsqa stopped working and was throwing an error like “302 : Site moved temporarily”.

Solution:

After troubleshooting this was caused by an incorrect password in the XML Link section of the Webprofile -> Security Tab.

After changing the userID and Password to the  correct one for the QA environment. This problem went away and they where able to access the xmllink using the excel spreadsheet.

Read More

DFS issues on some DCs only

2011-07-27 / Server / No Comment

Problem:

We had some issues with some users accessing the DFS shares.

Solution:

Turns out that our main filesystem went down  so DFS was routing everyone to our DR file server. However, the DR file server was in read only mode for users. We were able to track which DFS server the clients were connecting to by using

dfsutil /pktinfo

this assisted us in finding out the root cause of the strange errors. Even though the DFS MMC showed the DR site referral status as disabled the dfsutil showed us stuff was still connecting to it and using it actively.

Tags: ,
Read More

Have Multiple PeopleSoft Environments Opens In Internet Explorer

2011-07-27 / PeopleSoft / 1 Comment

Problem:

We had some users who needed to have a QA and PROD PeopleSoft environment open at the same time. When they would launch the second window it would log them off of the original peoplesoft environment.

Solution:

If you launch a “new session” in IE 8 it saves the cookies in the different location. This enables you to sign on to as many new peoplesoft sessions as you would like without losing your existing one.

Tags:
Read More

SCCM Use HTA To Set Task Sequence Variables

Problem:

I configured a task sequence to begin deployment of Windows 7 via USB thumb drives which are given to the techs. I wanted them to be able to install optional software at the time of deployment.

Solution:

UPDATED HTA FILE TO LATEST VERSION

Using Groups within the Task Sequences assigned variables gave me the best method of doing so. I created a front end HTA to allow the techs 1. set the PC name 2. add any additional software that the user might have had on their XP or replaced PC.

1.Mount current boot.wim file and then add HTA packages (if you dont already have HTA support)

Dism /image:c:\mountedwim /Add-Package /PackagePath:”C:\Program Files\Windows AIK\Tools\PETools\%Architecture%\WinPE_FPs\winpe-hta.cab”
Dism /image:c:\mountedwim /Add-Package /PackagePath:”C:\Program Files\Windows AIK\Tools\PETools\%Architecture%\WinPE_FPs\en-us\winpe-hta_en-us.cab”

2. Refresh/update boot image in SCCM

3. Configure Task Sequences to launch HTA

4. Configure groups with Task Sequence Variables

5. Configure HTA file
SCCMDeployments.hta.txt
(right click and save-as a text file and then rename to .hta once downloaded)
modify it to match your task sequence variables and the correct value it should be.
Keep in mind this will throw an error when not in the WinPE environment.

6. Deploy Image to USB Drive
No need to set variables on the Task sequence itself. When the image boots up and begins task sequence the HTA will run and prompt for check boxes and computer name value.

Read More

Atheros AR5007 with WPA WPA2 Issues

2011-06-17 / Desktop / 7 Comments

Problem:

After much troubleshooting it appears that Atheros AR5007 would not connect to any network with WPA/WPA2 encryption.

Solution:

I had to download an Atheros driver that was not listed on the Laptop Manufactures website. I found the driver at

http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadIndex?softwareitem=ob-82549-1&cc=mx&lc=es&dlc=es

This driver is listed at 7.7.0.396 and works with Vista 64 Bit. I have not tried it on other versions because I have no need to try.

Read More

Find which VM has snapshots on datastores

2011-04-14 / VMWare / No Comment

Problem: Many VMs had snapshots not listed in snapshot manager but still existed on the filesystem.

Solution:

Find all the snapshots on the datastores and clean them up by either cloning the virtual machine or command line tools.

Run this command on a host that has access to all the datastores you wish to scan.

find /vmfs/volumes/ -name “*delta*” -type f  -print0 | xargs -0 du –human-readable –total|less

Read More

Static Nat with Proxy ARP Juniper

2011-02-17 / Networking / No Comment

Problem:

When pinging/connecting to external NAT address, IP of the firewall/router was being returned.

Solution:

Configure a static nat with proxy arp

ssh into firewall

config shared
set security nat static rule-set MIPs rule VCD01XZZZ-BBB match destination-address 151.1xx.xx.210 (external)
set security nat static rule-set MIPs rule VCD01XZZZ-BBB then static-nat prefix 10.xxx.103.xxx (internal)
set security nat proxy-arp interface reth1.0 address 151.1xx.xx.210 (external)
set security zones security-zone trust address-book address VCD01XZZZ-BBB 10.xx.103.xxx (internal)
commit

 add to a policy via web config to save time.

Tags: ,
Read More